Protocol for Setting up Noldus EthoVision for Water Maze Testing

Introduction – 


Just like any other experiment, when we run the Water Maze, data accuracy and validity is the most important aspect of the entire process.  Due to this, it is extremely important that the EthoVision software is setup correctly and calibrated as close to perfect as possible to ensure that our results can be reproduced by another party.  I have tried to make this protocol as detailed and step-by-step as possible and hope it will facilitate the experiment’s success.

What purpose does EthoVision serve for our experiment? –


EthoVision helps us by recording and saving various data values for every rat that swims in the water maze.  By tracking the rat’s movement from the moment you drop the rat in the pool to when it finds the platform, we are able to quantify its swim speed, swim distance, time to find the escape platform and various other details that allow us to learn about the rat’s performance and ability to learn.

Step by Step instructions:

All commands and menu selections are in bold type.
Part I - Running EthoVision and very basic setup
1. Open the EthoVision program.  It should be in the Start menu or on the desktop.  The program has a security camera as its icon – look for this in case you are having trouble finding it.

2. Select the File menu in the top left corner and select New Workspace
3. A box should pop up showing you a current directory structure and asking you for a file name to enter that will then become the name of your new workspace.  Enter anything you’d like here (i.e. Gregs Workspace) and click once on the Save button to the right of where you entered in the filename. NOTE: DO NOT include any apostrophes in the name of any workspace or any experiment.  This can cause data corruption!

4. You should see a two pane window appear, with the left pane showing the name of your newly created workspace and the right pane showing the name and the number of current experiments (which is zero).

5. Select the File menu in the top left corner and select New and let the cascade menu open to then select Experiment.

6. Select a name for your experiment in the box that pops up.  If you are running a Water Maze, it is recommended to name it following a format such as Jan 07 Water Maze.  Select OK once you have entered in your desired experiment name.

7. Your newly titled experiment should now show in the left pane of the two pane display.  A description box will be showing in the right pane.  You may enter an overall description of your Water Maze experiment here.

8. Now click on the ‘+’ symbol in the left pane in front of the name of your newly created experiment to open up the collapsible menu.

9. From the menu at the top of your screen, select Experiment and then select Arena Definition.

10. A prompt box will pop up asking you for a video source.  From the Source dropdown menu, select Picolo.  For the Input Channel select S-Video (Mini DIN-4).  For the TV Standard select NTSC.  For the Acquisition resolution select High Resolution.

11. Highlight “Arena Profile” now and then select OK.

12. You should now see an image of your water maze tank provided that the camcorder is on and the camcorder’s video cable is connected to the back of the computer in the S-video “in” connection.  If you do not see an image right away, attempt to right mouse click over the black area where an image should be showing and then left mouse click on Refresh Background Image.  If right-clicking does not work, this step can also be completed by selecting the View menu from the top menu selection and then clicking on Refresh Background Image.  If for any reason you did not originally set the correct video source settings, you may also change these from the View menu by then selecting Select Background Source…
13. Note: This is not a live video feed and will not update on its own. It simply grabs a frame whenever you manually refresh the background image.

Part II – Setting up an Arena and Zones + Calibrating an Arena

14. Our goal in this section of the protocol is to define in which areas of the camera view our experiment takes place.  We will create a boundary, known as an arena, which will tell EthoVision the outer limit of our experimental zone.  For purposes of the Water Maze this is the black water maze tank. We’ll then setup areas for the escape platforms so that when the rat gets out of the water and sits on the escape platform, EthoVision will detect that and stop tracking and recording its movement.

15. Select the Arena menu at the very top of the screen and click on Add Arena…
16. Select a name for your arena, such as Water Maze 1 although you can just leave it as the default of Arena 1.  Now click OK.

17. If a large portion of the computer screen just turned green and you see a label with a pointer arrow showing your arena name, you’ve done this right.  Great!

18. Now, although we have created an arena and have named that arena we have yet to define the boundaries of that arena.  For this we will create a circle that will outline our experimental area (the water tank).  Select the Arena menu at the very top of the screen and click on 3 Point Circle.

19. Now move your mouse anywhere over the image of the tank and your mouse pointer should become a cross-hair instead of an arrow.  Use this cross-hair to select the very first point of your 3 point circle – left click anywhere on the boundary of the tank.  A red star should show up where you clicked.  Now click on the boundary of the tank on the opposite side of the tank and another red star should show up.  Now click anywhere else on the edge of the tank and you will have a yellow circle of which you can adjust the size or position.  To adjust the position, click and hold anywhere on the yellow circle’s boundary and move your mouse while still holding the left mouse button.  To adjust the size of the circle, left click and hold on a small yellow square seen on the border of the circle and adjust the size by moving your mouse.  You will be tempted to create the arena so that its boundaries match exactly with the boundaries of the black tank but this is not recommended.  The shiny edges of the tank can mess with the tracking system and the best way to create the arena’s perimeter is by having an assistant place a white piece of PVC pipe in the arena while the person at the computer Refreshes Background Image and gets an idea of the perimeter created by where the water actually is.
20. The way the arena and zone definitions work in EthoVision is that if you create a boundary (just as we did with the circle) it will work ONLY if the label for that boundary (the arena label that we made) is within the bounds of that boundary (in this case the circle).  To ensure that this is true, we go to the View menu at the very top of the screen and click on Fill Areas.  If the arena label is within the bounds of the arena circle, the circle should be filled with yellow color.  If it is not filled with yellow, move the label with your arena’s name on it until the circle is yellow.  To get a better understanding of this, even if your label is within the arena circle, try moving it outside of the circle and seeing what happens.  Just be sure to move it back inside the circle when you’re done.

21. Now near the bottom of the EthoVision screen, in the right pane, you should see three tabs, one that says Calibration, another that has the name of your arena, and the last one being Acquisition Zonedef.  Please left click on the tab named Acquisition Zonedef.

22. Now place your escape platform in the tank at escape position 0.  For the purpose of defining the escape platforms, use the Calibration Escape Platform – this is a ABS piping with a white circular platform on top of it, rather than the black one.  We use the white platform so that it can easily be seen on the EthoVision screen against the black water and it will allow us to correctly setup the escape zones.

23. Once you have placed the white Calibration Escape Platform in the water maze, right-click over any area of the tank image and select Refresh Background Image.  You may have to do this more than once to have the white piece of paper show up.

24. Once you see the white platform on the screen, select the Circle shape on the toolbar near the top of the EthoVision program.  You will see a few different shapes including a rectangle, a circle, an oval, and a line.  Select the circle and once again make a circle around the white platform showing up in the display.

25. Now select the Zone menu at the very top of EthoVision and select Add Zone.

26. Name the zone, P0 (for Platform 0) and select OK.

27. Move the label P0 that has just appeared so that its tail arrow points inside the blue circular zone you just created.  You will know you have done this correctly if only the inside of the blue circle is filled with color.

28. Repeat Steps 9-14 for the three remaining platforms (2, 4, and 6).  Name them appropriately (P2, P4, P6).  When done with this, proceed to the next step.

29. Now select the Zone menu at the very top of EthoVision and select Add Zone Definition.  Name the zone Quadrant ZD and select OK.

30. Now select the Zone menu at the very top of EthoVision and select Line from the dropdown menu.  Create a vertical line starting from the top of the arena and crossing through the center of the circle all the way to the bottom of the arena.  Hold down the CTRL key while dragging your line in order to make it straight. It is preferable if the line actually begins above the top of the arena and ends after it has passed the inferior border of the circle at the bottom.
31. Now select the Zone menu at the very top of EthoVision and once again select Line from the dropdown menu.  Create a horizontal line now, from one edge of the circular arena to the other, having it pass through the center and being perpendicular to the vertical line you just created.

32. Now select the Zone menu and select Add Zone….  Name the zone Quad 0 and drag the label arrow to the quadrant of the tank which begins with drop location 0.  Add 3 more zones from the Zone menu and name them Quad 2, Quad 4, and Quad 6 respectively.  Move them to the appropriate part of the maze. Click on the View menu at the top of EthoVision and make sure there is a check mark next to Fill Areas. You should now see four quadrants all with their individual color shading. If two quadrants have the same coloring, this means that one of your lines is not extending completely across the maze and therefore you have only three discrete areas rather than four.
33. Select the View menu at the very top of EthoVision and select Zoom and then select 200%
34. On the right pane of the two pane display in EthoVision, look near the bottom and you will see three tabs – Calibration, [Your Arena’s Name], and Acquisition Zonedef.  Select Calibration.

35. A new window should now popup on the top left of the screen titled Standard Calibration.  Here we will calibrate the tracking system of EthoVision so that we can have accurate data regarding rat swim speed and path length.  In order to do this you should find a standard 1 foot long ruler in the lab and place it on Escape Platform 0 and then select View menu from the top of EthoVision and select Refresh Background Image until you see the ruler show up on the screen.

36. Now click on the Add button on the Standard Calibration pop-up window in the top left of the screen.

37. Read the instructions given on the popup box and then click OK.  Select the two ends of the ruler in as straight of a line as possible and then enter in a value of 30.5 for the length.  It should automatically have the units of centimeters.

38. While keeping the ruler on the same platform, move it so that it is now perpendicular to the last orientation you had it in.  If the ruler was previously facing North-South, turn it to face East-West and Refresh Background Image again until you see the updated image.  Once again, add a calibration as you did in Steps 19-20.  Do this one more time for the same platform and turn the ruler at 45 degrees from its last orientation.

39. Now repeat Steps 19-21 for the remaining three platforms, having a minimum of three calibrations for each platform.  The more you have, the better your results will be but make sure you have at least three at every platform.

40. Select File menu from the top of EthoVision and click on Save Arena Profile. Select OK.
Part III – Setting up trial protocol and experiment controls

41. Select Experiment menu from the top of EthoVision and click on Acquire Data.

42. You should now see a live video feed of your tank area.  Put your hand somewhere over the tank if you don’t believe me! (
43. Now select Tracking menu from the top of EthoVision and click on Trial Protocol…
44. A pop-up box should now display titled Trial Protocol.  Recording duration will be by default set to 0000:00:05:00.000 – change this to 0000:00:01:30.000. Sample Rate will be set to 5.994 by default – change this to 9.990 samples/second.  In the checkboxes below make sure that ONLY Sound feedback is selected.

45. Now click on OK.

46. Select Tracking menu from the top of EthoVision and click on Experiment Control…
47. A new pop-up box should display titled Experiment Control.  Click on Add Location Condition.  For Arena select the name of your arena.  For Object select any Animal.  For Parameter leave it set to Time in zone.  For Zone in acquisition zone definition set it to any zone.  Change the Value to 5.0 and leave the Unit of time as seconds.  Leave “use this condition repeatedly” unchecked.  Click OK.

48. You should now see the condition showing in the Experiment Control box with two checkboxes on the right of it.  Select the checkbox on the right that corresponds with Stop recording. Click OK.

Part IV – Setting up tracking parameters

49. Select Tracking menu from the top of EthoVision and click on Processing and then click on Detection Method… 

50. A pop-up box should show up titled Processing Settings.  The current tab selected will be Detection Method.  On this tab make sure that Gray scaling is selected and that Object intensity is set to Object is always brighter than background.  Under noise removal set the Minimum object size and Maximum object size to 50 and 1200 respectively. If during the experiment you notice that some part of the rat is being shown as green rather than red on the tracking display, you may have to adjust the size settings as a green display means that EthoVision is NOT accurately tracking the rat due to it perceiving the rat as either too small or too large to be of any significance.
51. Click on the tab titled Area to Search.  Select Use scan window and set a scan window size to 115 pixels.  Change Automatic repositioning to Search complete arena. Leave the values below both set to 5. 

52. Click on the tab titled Image Filtering.  Check both the Erosion and Dilation boxes and select the values 1 pixel and 3 pixels, respectively.  Make sure the setting on the right is set to First erode, then dilate.

53. Click on the tab titled Image Enhancement. Experiment with increasing the contrast and brightness.  In the past, we have had to increase the contrast to its maximum setting and have had to also increase brightness somewhat in order for the maze to show up clearly enough for the system to track the animal.  This part of the protocol is by no means a one-size-fits all approach and will require fine tuning.  If you do not see any red (positive tracking) or green (noise) showing up on the screen when the rat is in the maze, return to the Image Enhancement menu and fine tune these settings.
54. Click OK.

You have now defined the parameters of the water maze apparatus completely and can now run the Water Maze experiment.  If the experiment design values have already been entered, you are ready to start Water Mazing.  If the design still needs to be entered, then continue reading below.

Part V – Entering Experiment Design Information
55. Select the Experiment menu from the top of EthoVision and then select Design.
56. Select the Variables menu from the top and select Add User-Defined Variable.
57. A new row will appear with the title New Label. Double click on this cell and rename the cell to Slate. In the cell to the right, enter a description of Unique Swim Identifier. Make sure under the Scope column it is set to Object.  In the Type column make sure it says Text.

58.  Again, select the Variables menu from the top and select Add User-Defined Variable. A new row will appear with the title New Label. Double click on this cell and rename the cell to Animal. In the description enter Animal ID #  and make sure the Scope is set to Object and that the Type is set to Numerical.  If it says Text, double click on the cell and select Numerical from the drop-down menu.
59. Add another variable as shown in Step 57, name it Group, with a description of Iso, Control, etc (DON’T UNHIDE) and make sure it is set to be an Object and a Numerical type. Now select the Variables menu from the top and select Show System Variables... and then check mark the Status box and select OK.
60. Add another variable as shown in Step 57, name it Session, with a description of Blocks of 3 trials and make sure it is set to be an Object and a Numerical type.

61. Add another variable as shown in Step 57, name it Trial, with a description of # Swim per rat and make sure it is set to be an Object and a Numerical type.

62. Add another variable as shown in Step 57, name it Platform, with a description of Escape Location and make sure it is set to be an Object and a Numerical type.

63. Add another variable as shown in Step 57, name it Drop, with a description of Drop Location and make sure it is set to be an Object and a Numerical type.
64. Now select the Values tab near the bottom of the screen and then from the top of EthoVision select the Tracks menu and click on Add Tracks.  Enter in the # of trials your water maze experiment will consist of – for example, if you have 50 rats and will have 3 trials per rat per session and will have 15 sessions plus 1 session of probe trials (where each rat will swim once rather than 3 times), you will add 2300 tracks.  ((50 * 3) * 15) + (50 * 1) = 2300.
65. Copy the data values that you have in your Water Maze Excel Template Static worksheet into EthoVision, very carefully.
66. Now click on the Definitions tab near the bottom of EthoVision and double click on the “X” checkbox on the left of the (in the Show column) Group cell, so that the box is no longer checked.  This will hide the Group row from the computer handler during the maze to preserve experiment blindness.

67. Once you have all those values entered, select the Experiment menu from the top of EthoVision and select Acquire Data.

68. Now push the F5 key to begin the first trial or select Tracking menu from the top of EthoVision and click on Start Trial…
Good luck!

If you have any questions that this protocol has not explained clearly, feel free to email me at rehansalvi@gmail.com and I would be glad to help!

-Rehan S. Alvi
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